Gransnet forums

Technology

Sorting emails on a mac

(9 Posts)
mrsmopp Wed 28-Aug-19 13:51:45

My mac will not sort my emails in date order, with latest emails at the top. I have to go in on Mail/ View/Sort by/Date each time. It’s so maddening it automatically reverts back to sorting them by subject.
How to put this right please?

Septimia Wed 28-Aug-19 14:02:14

Are you using the mail box on the Mac itself? I used to but it decided to stop linking with my internet email account when I got a new Mac. Obviously you know where the 'sort by' button is, but to the right of that is a circle with lines in that filters emails e.g. by 'unread'. Have you tried changing that?

That's about the extent of my knowledge!

Otherwise, if you're using bt, google etc for email then the settings should be on there, and changing the settings on that might send the messagfes through to the Mac in the way that you want them.

Technology is wonderful when it works!!

Willow500 Wed 28-Aug-19 14:35:03

How are you viewing your mail - is it directly on the net through your provider or through MS Outlook? If it's on the net then you need to do it via the provider settings e.g in BT it's 'Sort'- if it's in Outlook it's the drop down box which shows view by 'Date' Not sure how else you can do it otherwise.

WOODMOUSE49 Wed 28-Aug-19 14:40:23

When you're in mail - go preferences. Then go to viewing. Make sure the bottom box is ticked.

See the two snapshots I've done.

Good luck

mrsmopp Wed 28-Aug-19 17:53:43

Yes, I’m using the Mac mailbox, and every time I have to go to the top line, click on View/sort by/date to read the latest email. Then next time I check it has reverted back to selecting subject instead of date. So annoying. I must be doing something daft. I don’t see a circle with a line in it. Sorry.

NanaMacGeek Wed 28-Aug-19 19:10:23

mrsmopp, WOODMOUSE49 is giving you the answer. You are clicking the wrong box, don't click 'View' but click on 'Preferences' which comes up in the menu under 'Mail'. When the preferences menu opens, select the 'Viewing' tab (5th tab along after 'General', 'Accounts', 'Junk Mail' and 'Fonts & Colours'. Make sure the bottom box is ticked.

I hope the screenshot helps.

SpringyChicken Wed 28-Aug-19 22:00:23

If all else fails, take your MacBook to the Apple shop. The staff are brilliant and will help you, probably at no charge.

mrsmopp Wed 28-Aug-19 23:46:50

Thanks for all helpful replies. I don’t use the laptop very often as I find the iPad a lot easier, so I’m a bit out of practice. Getting rusty in my old age! Must try harder!
Well, thanks again, it’s appreciated. 🙂

BradfordLass72 Thu 29-Aug-19 23:41:26

Just being frivolous but when I read the title of this thread I had visions of someone collating all their letters which ahd been laid out on the usual waterproof coat...