Gransnet forums

Technology

NHS App

(9 Posts)
dragonfly46 Mon 24-May-21 15:23:37

Is anyone else having trouble downloading this.
My DH and I belong to the same GP practice and I had no trouble logging on to the app. I can get my Covid Vaccination records and even order my prescription.
My DH just gets a message saying they are having technical problems when he tries to log on. He has put in all his details etc and he did get in once but now no more.
What is even stranger is that he rang the surgery and they said they are not supporting the app - so how can I get on it?

tanith Mon 24-May-21 15:31:28

No it was fine when I downloaded it. All I can suggest is delete it and download again.

dragonfly46 Mon 24-May-21 16:17:05

We have tried that - we are quite computer savvy but this has stumped us!

shysal Mon 24-May-21 16:56:48

I had the 'technical problems' message when I tried using my surgery log-in codes. When I tried again using my passport for ID it worked!

kittylester Mon 24-May-21 17:55:34

DH and I have both logged on. I'm not sure what the benefit is though. I can get that on my practice website too.

Polarbear2 Mon 24-May-21 17:57:33

I had problems for a while but then it worked. I guessed it was just busy 🤷‍♀️ Doesn’t connect to my GP tho which I wanted it to.

dragonfly46 Tue 25-May-21 16:19:32

We did manage to sort it as the surgery had given us the wrong codes. A message to them soon put it right.

Gwyneth Tue 25-May-21 16:22:57

I can access my vaccination records which is the main reason I downloaded the app but am unable to access GP records or anything else.

Spidergran3 Tue 25-May-21 17:57:09

If your GP practice doesn’t support the app I shouldn’t think it’s much good anyway. Does your practice support the Patient Access app instead? It pretty much does the same thing.